From a8c86afaa52d3c6237e4085ac4e18ea91c8ba14d Mon Sep 17 00:00:00 2001
From: Efraim Flashner <efraim@flashner.co.il>
Date: Wed, 23 Oct 2019 10:01:14 +0300
Subject: [PATCH] gnu: Add rust-redox-termios-0.1.

* gnu/packages/rust-cbindgen.scm (rust-redox-termios-0.1): New hidden
variable.
---
 gnu/packages/rust-cbindgen.scm | 20 ++++++++++++++++++++
 1 file changed, 20 insertions(+)

diff --git a/gnu/packages/rust-cbindgen.scm b/gnu/packages/rust-cbindgen.scm
index 012b977b366..fcb57ca1304 100644
--- a/gnu/packages/rust-cbindgen.scm
+++ b/gnu/packages/rust-cbindgen.scm
@@ -566,3 +566,23 @@ (define rust-redox-syscall-0.1
 system calls.")
     (properties '((hidden? . #t)))
     (license license:expat)))
+
+(define rust-redox-termios-0.1
+  (package
+    (name "rust-redox-termios")
+    (version "0.1.1")
+    (source
+      (origin
+        (method url-fetch)
+        (uri (crate-uri "redox-termios" version))
+        (file-name (string-append name "-" version ".crate"))
+        (sha256
+         (base32
+          "0xhgvdh62mymgdl3jqrngl8hr4i8xwpnbsxnldq0l47993z1r2by"))))
+    (build-system cargo-build-system)
+    (home-page "https://github.com/redox-os/termios")
+    (synopsis "Rust library to access Redox termios functions")
+    (description
+     "This package provides a Rust library to access Redox termios functions.")
+    (properties '((hidden? . #t)))
+    (license license:expat)))
-- 
GitLab