From a9346faee6f61d7a2b0e066b110c9ce660827dbd Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Ludovic=20Court=C3=A8s?= <ludo@gnu.org>
Date: Wed, 18 Nov 2015 17:42:44 +0100
Subject: [PATCH] gnu: weechat: Record the absolute file name of 'python'.
MIME-Version: 1.0
Content-Type: text/plain; charset=UTF-8
Content-Transfer-Encoding: 8bit

Fixes <http://bugs.gnu.org/21879>.
Reported by Luis Felipe López Acevedo <felipe.lopez@openmailbox.org>.

* gnu/packages/weechat.scm (weechat)[arguments]: Add
  'set-python-file-name' phase.
---
 gnu/packages/weechat.scm | 11 ++++++++++-
 1 file changed, 10 insertions(+), 1 deletion(-)

diff --git a/gnu/packages/weechat.scm b/gnu/packages/weechat.scm
index 18508dd09d3..c0fd8c6c882 100644
--- a/gnu/packages/weechat.scm
+++ b/gnu/packages/weechat.scm
@@ -1,5 +1,6 @@
 ;;; GNU Guix --- Functional package management for GNU
 ;;; Copyright © 2014 Kevin Lemonnier <lemonnierk@ulrar.net>
+;;; Copyright © 2015 Ludovic Courtès <ludo@gnu.org>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -82,7 +83,15 @@ (define-public weechat
        #:phases (modify-phases %standard-phases
                   (add-before 'configure 'autogen
                     (lambda _
-                      (zero? (system* "./autogen.sh")))))))
+                      (zero? (system* "./autogen.sh"))))
+                  (add-before 'build 'set-python-file-name
+                    (lambda* (#:key inputs #:allow-other-keys)
+                      (substitute* "src/plugins/python/weechat-python.c"
+                        (("python2_bin = .*;")
+                         (string-append "python2_bin = \""
+                                        (assoc-ref inputs "python")
+                                        "/bin/python\";\n")))
+                      #t)))))
     (synopsis "Extensible chat client")
     (description "WeeChat (Wee Enhanced Environment for Chat) is an
 Internet Relay Chat client, which is designed to be light and fast.
-- 
GitLab