diff --git a/Makefile.am b/Makefile.am
index 5cf9314014dd476c2bd5d15602873af13d79e8ad..870c6f914b318fb2042ca03332cb475f08ded873 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -389,9 +389,12 @@ gen-ChangeLog:
 	fi
 
 gen-AUTHORS:
-	$(top_builddir)/pre-inst-env "$(GUILE)"			\
-	  "$(top_srcdir)/build-aux/generate-authors.scm"	\
-	  "$(top_srcdir)" "$(distdir)/AUTHORS"
+	if test -d .git; then					\
+	  rm -f "$(distdir)/AUTHORS";				\
+	  $(top_builddir)/pre-inst-env "$(GUILE)"		\
+	    "$(top_srcdir)/build-aux/generate-authors.scm"	\
+	    "$(top_srcdir)" "$(distdir)/AUTHORS";		\
+	fi
 
 # Make sure we're not shipping a file that embeds a local /gnu/store file name.
 assert-no-store-file-names: