diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 5b1123810922bedfbdba68117ae9c42b2713cbda..3fd8ee3149015744ddaffb64d0198bcebce948f7 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -2341,9 +2341,9 @@ (define-public vte
     (version "0.56.3")
     (source (origin
               (method url-fetch)
-              (uri (string-append "mirror://gnome/sources/" name "/"
+              (uri (string-append "mirror://gnome/sources/vte/"
                                   (version-major+minor version) "/"
-                                  name "-" version ".tar.xz"))
+                                  "vte-" version ".tar.xz"))
               (sha256
                (base32
                 "0j166gic5znssdb9r45qazq4kb4v9fial82czand5wa8i2yd988p"))))