diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index b099fcf0415db4d148101f8870e83e0daf6bfeb8..76638cb5a7bd581f33cff91a3a6f17bfd023c1e0 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -7682,3 +7682,28 @@ (define-public python2-mako
       (native-inputs
        (cons `("python2-setuptools" ,python2-setuptools)
              (package-native-inputs base))))))
+
+(define-public python-waitress
+  (package
+    (name "python-waitress")
+    (version "0.8.10")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "waitress" version))
+       (sha256
+        (base32
+         "017n9ra6vvmq9d5sfhdzyzr1mg15x2hj2dhm4pdlw98c1ypw2h3w"))))
+    (build-system python-build-system)
+    (home-page "https://github.com/Pylons/waitress")
+    (synopsis "Waitress WSGI server")
+    (description "Waitress is meant to be a production-quality pure-Python WSGI
+server with very acceptable performance.")
+    (license zpl2.1)
+    (properties `((python2-variant . ,(delay python2-waitress))))))
+
+(define-public python2-waitress
+  (package
+    (inherit (package-with-python2
+              (strip-python2-variant python-waitress)))
+    (native-inputs `(("python2-setuptools" ,python2-setuptools)))))