From af5b817ea9f4320b4cbffc85b3f57223a5b9463c Mon Sep 17 00:00:00 2001
From: Ricardo Wurmus <rekado@elephly.net>
Date: Wed, 25 Mar 2015 19:20:11 +0100
Subject: [PATCH] gnu: openblas: build for all supported CPUs.

* gnu/packages/maths.scm (openblas)[arguments]: Add "DYNAMIC_ARCH=1" to
  make flags.  Remove "#:substitutable? #f".
---
 gnu/packages/maths.scm | 7 +++++--
 1 file changed, 5 insertions(+), 2 deletions(-)

diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index 49667cc71b0..417af4a91bc 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -1033,11 +1033,14 @@ (define-public openblas
     (build-system gnu-build-system)
     (arguments
      '(#:tests? #f  ;no "check" target
-       #:substitutable? #f ;force local build because of CPU detection
        #:make-flags
        (list (string-append "PREFIX=" (assoc-ref %outputs "out"))
              "SHELL=bash"
-             "NO_LAPACK=1")
+             "NO_LAPACK=1"
+             ;; Build the library for all supported CPUs.  This allows
+             ;; switching CPU targets at runtime with the environment variable
+             ;; OPENBLAS_CORETYPE=<type>, where "type" is a supported CPU type.
+             "DYNAMIC_ARCH=1")
        ;; no configure script
        #:phases (alist-delete 'configure %standard-phases)))
     (inputs
-- 
GitLab