From af89a6673522a0260f04ae503b53813c053ca26f Mon Sep 17 00:00:00 2001
From: Federico Beffa <beffa@fbengineering.ch>
Date: Sat, 22 Nov 2014 16:42:41 +0100
Subject: [PATCH] gnu: atlas: Try to fix build on MIPS.

* gnu/packages/maths.scm (atlas): Add MIPS specific configure flags.
---
 gnu/packages/maths.scm | 6 ++++++
 1 file changed, 6 insertions(+)

diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index 1aa3757ebe7..cc068b98c7d 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -979,6 +979,12 @@ (define-public atlas
          ;; Disable parallel build as it gives errors: atlas_pthread.h is
          ;; needed to compile C files before it is generated.
          "-Ss" "pmake" "make -j 1"
+         ;; Probe is failing for MIPS.  We therefore define the system
+         ;; architecture explicitly by setting (-A) MACHINETYPE = 49
+         ;; 'MIPSR1xK' and (-V) ISA = 1 'none'.
+         ,,@(if (string-prefix? "mips" (%current-system))
+              (list "-A" "49" "-V" "1")
+              (list))
          ;; Generate shared libraries.
          "--shared"
          ;; Build a full LAPACK library.
-- 
GitLab