From b0aa6ede251709f650b30020057a86da8c636f99 Mon Sep 17 00:00:00 2001
From: Hartmut Goebel <h.goebel@crazy-compilers.com>
Date: Fri, 2 Dec 2016 15:05:19 +0100
Subject: [PATCH] gnu: python-numpy: Fix inputs.

This fixes 2efabc5589dc641dce75702b99253a3fb40bb2eb, where some inputs
have been changed to propagated-inputs, but the propagated-inputs are
still extended from inputs and the inputs are not extended at all.

* gnu/packages/python.scm (python-numpy, python2-numpy)[inputs]:
Extend from python-numpy-bootstrap's package-inputs. [propagated-inputs]:
Extend from python-numpy-bootstrap's package-propagated-inputs.
---
 gnu/packages/python.scm | 5 +++--
 1 file changed, 3 insertions(+), 2 deletions(-)

diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index c2dac257060..e3738696b4f 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -3261,11 +3261,12 @@ (define-public python-numpy
     (name "python-numpy")
     (outputs '("out" "doc"))
     (inputs
-     `(("which" ,which)))
+     `(("which" ,which)
+       ,@(package-inputs python-numpy-bootstrap)))
     (propagated-inputs
      `(("python-matplotlib" ,python-matplotlib)
        ("python-pyparsing" ,python-pyparsing)
-       ,@(package-inputs python-numpy-bootstrap)))
+       ,@(package-propagated-inputs python-numpy-bootstrap)))
     (native-inputs
      `(("pkg-config" ,pkg-config)
        ("python-sphinx" ,python-sphinx)
-- 
GitLab