From b1006576d7f233cf04ae149e8d089fe51203e0e8 Mon Sep 17 00:00:00 2001
From: Ricardo Wurmus <rekado@elephly.net>
Date: Mon, 28 Sep 2015 15:23:10 +0200
Subject: [PATCH] gnu: Add r-htmlwidgets.

* gnu/packages/web.scm (r-htmlwidgets): New variable.
---
 gnu/packages/web.scm | 23 +++++++++++++++++++++++
 1 file changed, 23 insertions(+)

diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index fb76015cea7..4d526fce0cb 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -2954,3 +2954,26 @@ (define-public r-htmltools
     (description
      "This package provides tools for HTML generation and output in R.")
     (license l:expat)))
+
+(define-public r-htmlwidgets
+  (package
+    (name "r-htmlwidgets")
+    (version "0.5")
+    (source (origin
+              (method url-fetch)
+              (uri (cran-uri "htmlwidgets" version))
+              (sha256
+               (base32
+                "1d583kk7g29r4sq0y1scri7fs48z6q17c051nyjywcvnpy4lvi8j"))))
+    (build-system r-build-system)
+    (propagated-inputs
+     `(("r-htmltools" ,r-htmltools)
+       ("r-jsonlite" ,r-jsonlite)
+       ("r-yaml" ,r-yaml)))
+    (home-page "https://github.com/ramnathv/htmlwidgets")
+    (synopsis "HTML Widgets for R")
+    (description
+     "HTML widgets is a framework for creating HTML widgets that render in
+various contexts including the R console, R Markdown documents, and Shiny web
+applications.")
+    (license l:expat)))
-- 
GitLab