From b35c0f866c83288e64dcf5839d908705d416c317 Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Ludovic=20Court=C3=A8s?= <ludo@gnu.org>
Date: Thu, 13 Dec 2012 22:08:33 +0100
Subject: [PATCH] release.nix: Add `build_disable_daemon'.

* release.nix (build_disable_daemon): New job.
---
 release.nix | 17 +++++++++++++++++
 1 file changed, 17 insertions(+)

diff --git a/release.nix b/release.nix
index 4c54f75b0af..2d3a70f524a 100644
--- a/release.nix
+++ b/release.nix
@@ -86,6 +86,23 @@ let
       };
 
 
+    build_disable_daemon =
+      { system ? builtins.currentSystem }:
+
+      let
+        pkgs = import nixpkgs { inherit system; };
+        build = jobs.build { inherit system; };
+      in
+        pkgs.lib.overrideDerivation build ({ configureFlags, ... }: {
+          configureFlags = configureFlags ++ [ "--disable-daemon" ];
+          buildInputs = with pkgs; [ guile nixUnstable pkgconfig ];
+
+          # Since we need to talk to a running daemon, we need to escape
+          # the chroot.
+          preConfigure = "export NIX_REMOTE=daemon";
+          __noChroot = true;
+        });
+
     # Jobs to test the distro.
     distro = {
       hello =
-- 
GitLab