From b856a78c949543da2cb829b36cb96e74309e8d35 Mon Sep 17 00:00:00 2001
From: Efraim Flashner <efraim@flashner.co.il>
Date: Tue, 12 Feb 2019 18:08:06 +0200
Subject: [PATCH] gnu: efilinux: Set ARCH variable on some architectures.

Even with this patch efilinux does not build for arm*.

* gnu/packages/efi.scm (efilinux)[arguments]: On armhf-linux and
aarch64-linux set the ARCH variable apropriately.
---
 gnu/packages/efi.scm | 10 +++++++++-
 1 file changed, 9 insertions(+), 1 deletion(-)

diff --git a/gnu/packages/efi.scm b/gnu/packages/efi.scm
index 43e660743a8..49ca7400887 100644
--- a/gnu/packages/efi.scm
+++ b/gnu/packages/efi.scm
@@ -1,5 +1,6 @@
 ;;; GNU Guix --- Functional package management for GNU
 ;;; Copyright © 2019 Danny Milosavljevic <dannym@scratchpost.org>
+;;; Copyright © 2019 Efraim Flashner <efraim@flashner.co.il>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -29,7 +30,8 @@ (define-module (gnu packages efi)
   #:use-module (guix download)
   #:use-module (guix git-download)
   #:use-module (guix packages)
-  #:use-module (guix utils))
+  #:use-module (guix utils)
+  #:use-module (ice-9 match))
 
 (define-public gnu-efi
   (package
@@ -195,6 +197,12 @@ (define-public efilinux
     (arguments
      `(#:make-flags
        (list "CC=gcc"
+             ,@(match (%current-system)
+                 ("aarch64-linux"
+                  '("ARCH=aarch64"))
+                 ("armhf-linux"
+                  '("ARCH=arm"))
+                 (_ '()))
              (string-append "INCDIR=" (assoc-ref %build-inputs "gnu-efi")
                             "/include")
              (string-append "LIBDIR=" (assoc-ref %build-inputs "gnu-efi")
-- 
GitLab