diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 4c68e636c01a8669a94348279c8d09b42220367f..006151bc37fdf227e15a56e93a7062b23f87ed44 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -852,8 +852,7 @@ (define-public python-zope-interface
     (source
      (origin
        (method url-fetch)
-       (uri (string-append "https://pypi.python.org/packages/source/z"
-                           "/zope.interface/zope.interface-" version ".tar.gz"))
+       (uri (pypi-uri "zope.interface" version))
        (sha256
         (base32
          "0ks8h73b2g4bkad821qbv0wzjppdrwys33i7ka45ik3wxjg1l8if"))))