From bad12e839c2f7823c45aa0121f7d5c9bb70905b7 Mon Sep 17 00:00:00 2001
From: Leo Famulari <leo@famulari.name>
Date: Sat, 13 Jan 2018 17:21:42 -0800
Subject: [PATCH] gnu: rct: Re-categorize some inputs.

OpenSSL and zlib are referred to by the built package, so we make them
regular inputs.

This is a followup to commit e8b409741baf3b9de30faa8683722375196dd1e9.

* gnu/packages/cpp.scm (rct)[native-inputs]: Move openssl and zlib to ...
[inputs]: ... new field.
---
 gnu/packages/cpp.scm | 5 +++--
 1 file changed, 3 insertions(+), 2 deletions(-)

diff --git a/gnu/packages/cpp.scm b/gnu/packages/cpp.scm
index 86915310708..7f711d55426 100644
--- a/gnu/packages/cpp.scm
+++ b/gnu/packages/cpp.scm
@@ -89,8 +89,9 @@ (define-public rct
          '("-DWITH_TESTS=ON")))           ; To run the test suite
       (native-inputs
        `(("cppunit" ,cppunit)
-         ("openssl" ,openssl)
-         ("pkg-config" ,pkg-config)
+         ("pkg-config" ,pkg-config)))
+      (inputs
+       `(("openssl" ,openssl)
          ("zlib" ,zlib)))
       (synopsis "C++ library providing Qt-like APIs on top of the STL")
       (description "Rct is a set of C++ tools that provide nicer (more Qt-like)
-- 
GitLab