From bae187105907a1fe94fb2f6a661920299b9cd877 Mon Sep 17 00:00:00 2001
From: Leo Famulari <leo@famulari.name>
Date: Sat, 29 Oct 2016 21:08:30 -0400
Subject: [PATCH] gnu: python-prompt-toolkit: Disable the test suite.

The tests were silently skipped with Python 3.4. With Python 3.5, this caused
the build of python-prompt-toolkit to fail.

* gnu/packages/python.scm (python-prompt-toolkit,
python2-prompt-toolkit)[arguments]: Disable the tests.
---
 gnu/packages/python.scm | 2 ++
 1 file changed, 2 insertions(+)

diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index a25d3bca4c7..55efd4d4c0c 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -10151,6 +10151,8 @@ (define-public python-prompt-toolkit
         (base32
           "1vyjd0b7wciv55i19l44zy0adx8q7ss79lhy2r9d1rwz2y4822zg"))))
   (build-system python-build-system)
+  (arguments
+   '(#:tests? #f)) ; The test suite uses some Windows-specific data types.
   (inputs `(("python-wcwidth" ,python-wcwidth)
             ("python-pygments" ,python-pygments)))
   (native-inputs `(("python-six" ,python-six)))
-- 
GitLab