diff --git a/gnu-system.am b/gnu-system.am
index d3b822c169a0acc531034496e59c9d011b07ce57..4c9fcda8b95c1432e95335f6871a77167e42e397 100644
--- a/gnu-system.am
+++ b/gnu-system.am
@@ -435,6 +435,7 @@ dist_patch_DATA =						\
   gnu/packages/patches/vpnc-script.patch			\
   gnu/packages/patches/w3m-fix-compile.patch			\
   gnu/packages/patches/xf86-input-synaptics-glibc-2.20.patch	\
+  gnu/packages/patches/xf86-video-openchrome-includes.patch	\
   gnu/packages/patches/xmodmap-asprintf.patch
 
 bootstrapdir = $(guilemoduledir)/gnu/packages/bootstrap
diff --git a/gnu/packages/patches/xf86-video-openchrome-includes.patch b/gnu/packages/patches/xf86-video-openchrome-includes.patch
new file mode 100644
index 0000000000000000000000000000000000000000..3c79596387780a32f61e6a675b89e5b934325104
--- /dev/null
+++ b/gnu/packages/patches/xf86-video-openchrome-includes.patch
@@ -0,0 +1,35 @@
+This follows the same rationale as xf86-input-synaptics-glibc-2.20.patch
+to allow building with glibc-2.20.
+diff -u -r xf86-video-openchrome-0.2.906.old/src/via_3d.h xf86-video-openchrome-0.2.906/src/via_3d.h
+--- xf86-video-openchrome-0.2.906.old/src/via_3d.h	2014-11-23 14:04:58.000000000 +0100
++++ xf86-video-openchrome-0.2.906/src/via_3d.h	2014-11-23 14:18:37.000000000 +0100
+@@ -24,6 +24,7 @@
+ #ifndef VIA_3D_H
+ #define VIA_3D_H
+ 
++#include "xorg-server.h"
+ #include "xf86.h"
+ #include "via_dmabuffer.h"
+ 
+diff -u -r xf86-video-openchrome-0.2.906.old/src/via_driver.h xf86-video-openchrome-0.2.906/src/via_driver.h
+--- xf86-video-openchrome-0.2.906.old/src/via_driver.h	2014-11-23 14:04:58.000000000 +0100
++++ xf86-video-openchrome-0.2.906/src/via_driver.h	2014-11-23 14:21:43.000000000 +0100
+@@ -35,6 +35,7 @@
+ #endif
+ 
+ #include "vgaHW.h"
++#include "xorg-server.h"
+ #include "xf86.h"
+ 
+ #if GET_ABI_MAJOR(ABI_VIDEODRV_VERSION) < 6 
+diff -u -r xf86-video-openchrome-0.2.906.old/src/via_timing.h xf86-video-openchrome-0.2.906/src/via_timing.h
+--- xf86-video-openchrome-0.2.906.old/src/via_timing.h	2014-11-23 14:04:58.000000000 +0100
++++ xf86-video-openchrome-0.2.906/src/via_timing.h	2014-11-23 14:20:50.000000000 +0100
+@@ -25,6 +25,7 @@
+ #ifndef _TIMING_H_
+ #define _TIMING_H_
+ 
++#include "xorg-server.h"
+ #include "xf86.h"
+ 
+ /* Aspect ratio not CVT standard */
diff --git a/gnu/packages/xorg.scm b/gnu/packages/xorg.scm
index 41c6a039325f9d5522d90d138b0821a1d6150729..292845c64e9dbc2e4c2c222837c0807e88cd9060 100644
--- a/gnu/packages/xorg.scm
+++ b/gnu/packages/xorg.scm
@@ -2843,7 +2843,8 @@ (define-public xf86-video-openchrome
                ".tar.bz2"))
         (sha256
           (base32
-            "0hgzn1r7ig94xbr9dvq0bp1nxqlfp2ki8823jca3f22a2kf8wmg7"))))
+            "0hgzn1r7ig94xbr9dvq0bp1nxqlfp2ki8823jca3f22a2kf8wmg7"))
+        (patches (list (search-patch "xf86-video-openchrome-includes.patch")))))
     (build-system gnu-build-system)
     (inputs `(("libx11" ,libx11)
               ("libxext" ,libxext)