From bd9174860c5468970f7d154e646def470255ea1d Mon Sep 17 00:00:00 2001
From: Thomas Danckaert <thomas.danckaert@gmail.com>
Date: Sat, 5 Nov 2016 21:18:13 +0100
Subject: [PATCH] gnu: texmaker: Use modular qt and qtwebkit.
MIME-Version: 1.0
Content-Type: text/plain; charset=UTF-8
Content-Transfer-Encoding: 8bit

* gnu/packages/tex.scm (texmaker)[inputs]: Use modular qt and qtwebkit.

Signed-off-by: Ludovic Courtès <ludo@gnu.org>
---
 gnu/packages/tex.scm | 5 ++++-
 1 file changed, 4 insertions(+), 1 deletion(-)

diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index c8114c20778..9186e4693aa 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -5,6 +5,7 @@
 ;;; Copyright © 2016 Roel Janssen <roel@gnu.org>
 ;;; Copyright © 2016 Efraim Flashner <efraim@flashner.co.il>
 ;;; Copyright © 2016 Federico Beffa <beffa@fbengineering.ch>
+;;; Copyright © 2016 Thomas Danckaert <post@thomasdanckaert.be>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -439,7 +440,9 @@ (define-public texmaker
                                "texmaker.pro"))))))))
     (inputs
      `(("poppler-qt5" ,poppler-qt5)
-       ("qt" ,qt)
+       ("qtbase" ,qtbase)
+       ("qtscript" ,qtscript)
+       ("qtwebkit" ,qtwebkit)
        ("zlib" ,zlib)))
     (native-inputs
      `(("pkg-config" ,pkg-config)))
-- 
GitLab