diff --git a/gnu/packages/messaging.scm b/gnu/packages/messaging.scm
index be39d14b5312be12805498996fa02af4ff15f3bb..80afd11d3dcf217ab797552f49257ebd45e959cb 100644
--- a/gnu/packages/messaging.scm
+++ b/gnu/packages/messaging.scm
@@ -186,18 +186,18 @@ (define-public bitlbee
        (modify-phases %standard-phases
          (add-after 'install 'install-etc
            (lambda* (#:key (make-flags '()) #:allow-other-keys)
-             (zero? (apply system* "make" "install-etc" make-flags))))
+             (apply invoke "make" "install-etc" make-flags)))
          (add-after 'install-etc 'install-lib
            (lambda* (#:key (make-flags '()) #:allow-other-keys)
-             (zero? (apply system* "make" "install-dev" make-flags))))
+             (apply invoke "make" "install-dev" make-flags)))
          (replace 'configure
            ;; bitlbee's configure script does not tolerate many of the
            ;; variable settings that Guix would pass to it.
            (lambda* (#:key outputs #:allow-other-keys)
-             (zero? (system* "./configure"
-                             (string-append "--prefix="
-                                            (assoc-ref outputs "out"))
-                             "--otr=1")))))))
+             (invoke "./configure"
+                     (string-append "--prefix="
+                                    (assoc-ref outputs "out"))
+                     "--otr=1"))))))
     (synopsis "IRC to instant messaging gateway")
     (description "BitlBee brings IM (instant messaging) to IRC clients, for
 people who have an IRC client running all the time and don't want to run an