diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index 1f150fdc050cd83f2ba243fab07b9a98d16f4c71..5f133180116e53c3c1b6a8b5b91745593e8268ce 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -788,3 +788,24 @@ (define-public ruby-minitar
 that provides the ability to deal with POSIX tar archive files.")
     (home-page "http://www.github.com/atoulme/minitar")
     (license (list license:gpl2+ license:ruby))))
+
+(define-public ruby-mini-portile
+  (package
+    (name "ruby-mini-portile")
+    (version "0.6.2")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (rubygems-uri "mini_portile" version))
+       (sha256
+        (base32
+         "0h3xinmacscrnkczq44s6pnhrp4nqma7k056x5wv5xixvf2wsq2w"))))
+    (build-system ruby-build-system)
+    (arguments
+     '(#:tests? #f)) ; tests require network access
+    (synopsis "Ports system for Ruby developers")
+    (description "Mini-portile is a port/recipe system for Ruby developers.
+It provides a standard way to compile against specific versions of libraries
+to reproduce user environments.")
+    (home-page "http://github.com/flavorjones/mini_portile")
+    (license license:expat)))