From bee9f97e0ae55c1d4c7e35ddd1c31be24ff32e23 Mon Sep 17 00:00:00 2001
From: Christopher Baines <mail@cbaines.net>
Date: Sun, 7 Jul 2019 18:54:29 +0100
Subject: [PATCH] gnu: Add s-tui.

* gnu/packages/admin.scm (s-tui): New variable.
---
 gnu/packages/admin.scm | 22 ++++++++++++++++++++++
 1 file changed, 22 insertions(+)

diff --git a/gnu/packages/admin.scm b/gnu/packages/admin.scm
index 1c49e4565ee..3ce39b03e68 100644
--- a/gnu/packages/admin.scm
+++ b/gnu/packages/admin.scm
@@ -1453,6 +1453,28 @@ (define-public acpica
 development, not the kernel implementation of ACPI.")
     (license license:gpl2)))            ; dual GPLv2/ACPICA Licence
 
+(define-public s-tui
+  (package
+    (name "s-tui")
+    (version "0.8.3")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "s-tui" version))
+       (sha256
+        (base32
+         "00lsh2v4i8rwfyjyxx5lijd6rnk9smcfffhzg5sv94ijpcnh216m"))))
+    (build-system python-build-system)
+    (inputs
+     `(("python-psutil" ,python-psutil)
+       ("python-urwid" ,python-urwid)))
+    (home-page "https://github.com/amanusk/s-tui")
+    (synopsis "Interactive terminal stress test and monitoring tool")
+    (description
+     "The Stress Terminal UI displays graphs of the CPU frequency,
+utilization, temperature and power.")
+    (license license:gpl2+)))
+
 (define-public stress
   (package
     (name "stress")
-- 
GitLab