diff --git a/gnu/packages/textutils.scm b/gnu/packages/textutils.scm
index cda79231f1f1bc1b32f4586d1cb6bca3fc21fda9..1ea9c95407749114e9b08ccebc027e1fe7f3c1de 100644
--- a/gnu/packages/textutils.scm
+++ b/gnu/packages/textutils.scm
@@ -758,12 +758,13 @@ (define-public opencc
     (version "1.0.5")
     (source
      (origin
-       (method url-fetch)
-       (uri (string-append "https://github.com/BYVoid/OpenCC"
-                           "/archive/ver." version ".tar.gz"))
-       (file-name (string-append name "-" version ".tar.gz"))
+       (method git-fetch)
+       (uri (git-reference
+              (url "https://github.com/BYVoid/OpenCC")
+              (commit (string-append "ver." version))))
+       (file-name (git-file-name name version))
        (sha256
-        (base32 "01870gbkf711msirf3206k0ajaabypjhnx3fny5wikw0ladn9q8w"))))
+        (base32 "1pv5md225qwhbn8ql932zdg6gh1qlx3paiajaks8gfsa07yzvhr4"))))
     (build-system cmake-build-system)
     (native-inputs
      `(("python" ,python-wrapper)))