From bf5af9342c6dd364242c162db00436c9708e8d5b Mon Sep 17 00:00:00 2001
From: Efraim Flashner <efraim@flashner.co.il>
Date: Sun, 23 Dec 2018 19:14:12 +0200
Subject: [PATCH] gnu: opencc: Use 'git-fetch'.

* gnu/packages/textutils.scm (opencc)[source]: Use 'git-fetch'.
---
 gnu/packages/textutils.scm | 11 ++++++-----
 1 file changed, 6 insertions(+), 5 deletions(-)

diff --git a/gnu/packages/textutils.scm b/gnu/packages/textutils.scm
index cda79231f1f..1ea9c954077 100644
--- a/gnu/packages/textutils.scm
+++ b/gnu/packages/textutils.scm
@@ -758,12 +758,13 @@ (define-public opencc
     (version "1.0.5")
     (source
      (origin
-       (method url-fetch)
-       (uri (string-append "https://github.com/BYVoid/OpenCC"
-                           "/archive/ver." version ".tar.gz"))
-       (file-name (string-append name "-" version ".tar.gz"))
+       (method git-fetch)
+       (uri (git-reference
+              (url "https://github.com/BYVoid/OpenCC")
+              (commit (string-append "ver." version))))
+       (file-name (git-file-name name version))
        (sha256
-        (base32 "01870gbkf711msirf3206k0ajaabypjhnx3fny5wikw0ladn9q8w"))))
+        (base32 "1pv5md225qwhbn8ql932zdg6gh1qlx3paiajaks8gfsa07yzvhr4"))))
     (build-system cmake-build-system)
     (native-inputs
      `(("python" ,python-wrapper)))
-- 
GitLab