diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 012deaa1e08994d47298aa6b2029c4c5c7351b17..03e7584f54fe17b7199ca64e2ad68c61273a2528 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -3863,6 +3863,8 @@ (define-public star
 detection of canonical junctions, STAR can discover non-canonical splices and
 chimeric (fusion) transcripts, and is also capable of mapping full-length RNA
 sequences.")
+    ;; Only 64-bit systems are supported according to the README.
+    (supported-systems '("x86_64-linux" "mips64el-linux"))
     ;; STAR is licensed under GPLv3 or later; htslib is MIT-licensed.
     (license license:gpl3+)))