From c11f79a49ee64800c44929ec072e9b1f8b0765d0 Mon Sep 17 00:00:00 2001
From: Ben Woodcroft <donttrustben@gmail.com>
Date: Fri, 8 Jul 2016 22:08:16 +1000
Subject: [PATCH] gnu: star: Restrict supported systems to 64-bit systems.

* gnu/packages/bioinformatics.scm (star)[supported-systems]: Restrict to
x86_64-linux and mips64el-linux.
---
 gnu/packages/bioinformatics.scm | 2 ++
 1 file changed, 2 insertions(+)

diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 012deaa1e08..03e7584f54f 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -3863,6 +3863,8 @@ (define-public star
 detection of canonical junctions, STAR can discover non-canonical splices and
 chimeric (fusion) transcripts, and is also capable of mapping full-length RNA
 sequences.")
+    ;; Only 64-bit systems are supported according to the README.
+    (supported-systems '("x86_64-linux" "mips64el-linux"))
     ;; STAR is licensed under GPLv3 or later; htslib is MIT-licensed.
     (license license:gpl3+)))
 
-- 
GitLab