From c397e502ca4f9a929e213e1c728b942a007ee278 Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Ludovic=20Court=C3=A8s?= <ludo@gnu.org>
Date: Tue, 8 Apr 2014 14:07:53 +0200
Subject: [PATCH] gnu: dvdisaster: Build sequentially.

* gnu/packages/cdrom.scm (dvdisaster)[arguments]: Add #:parallel-build? #f.
---
 gnu/packages/cdrom.scm | 7 +++++--
 1 file changed, 5 insertions(+), 2 deletions(-)

diff --git a/gnu/packages/cdrom.scm b/gnu/packages/cdrom.scm
index 942f8982107..11bfa2f7cf9 100644
--- a/gnu/packages/cdrom.scm
+++ b/gnu/packages/cdrom.scm
@@ -1,5 +1,5 @@
 ;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2013 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2013, 2014 Ludovic Courtès <ludo@gnu.org>
 ;;; Copyright © 2013 Andreas Enge <andreas@enge.fr>
 ;;;
 ;;; This file is part of GNU Guix.
@@ -189,7 +189,10 @@ (define-public dvdisaster
        ("pkg-config" ,pkg-config)
        ("which" ,which)))
     (arguments
-     `(#:tests? #f)) ; no check target
+     `(;; Parallel builds appear to be unsafe, see
+       ;; <http://hydra.gnu.org/build/49331/nixlog/1/raw>.
+       #:parallel-build? #f
+       #:tests? #f)) ; no check target
     (home-page "http://dvdisaster.net/en/index.html")
     (synopsis "error correcting codes for optical media images")
     (description "Optical media (CD,DVD,BD) keep their data only for a
-- 
GitLab