From c3c61a781c5e8d1b50f744b7f3640156762d5fee Mon Sep 17 00:00:00 2001
From: Eric Bavier <bavier@member.fsf.org>
Date: Wed, 18 Nov 2015 19:12:41 -0600
Subject: [PATCH] gnu: ghc-unordered-containers: Enable tests.

* gnu/packages/haskell.scm (ghc-unordered-containers)
  [arguments]: Remove.
  [inputs]: Add ghc-chasingbottoms, ghc-test-framework,
  ghc-test-framework-hunit, and ghc-test-framework-quickcheck2.
---
 gnu/packages/haskell.scm | 10 ++++++----
 1 file changed, 6 insertions(+), 4 deletions(-)

diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index dc361eb1725..137f6e9ee15 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -3051,12 +3051,14 @@ (define-public ghc-unordered-containers
          "06l1xv7vhpxly75saxdrbc6p2zlgz1az278arfkz4rgawfnphn3f"))))
     (build-system haskell-build-system)
     (inputs
-     `(("ghc-hunit" ,ghc-hunit)
-       ("ghc-quickcheck" ,ghc-quickcheck)))
+     `(("ghc-chasingbottoms" ,ghc-chasingbottoms)
+       ("ghc-hunit" ,ghc-hunit)
+       ("ghc-quickcheck" ,ghc-quickcheck)
+       ("ghc-test-framework" ,ghc-test-framework)
+       ("ghc-test-framework-hunit" ,ghc-test-framework-hunit)
+       ("ghc-test-framework-quickcheck2" ,ghc-test-framework-quickcheck2)))
     ;; these inputs are necessary to use this library
     (propagated-inputs `(("ghc-hashable" ,ghc-hashable)))
-    (arguments
-     `(#:tests? #f)) ; FIXME: currently missing libraries used for tests.
     (home-page
      "https://github.com/tibbe/unordered-containers")
     (synopsis
-- 
GitLab