From c44fb4df8a2114b482285d522033050c1c94dfba Mon Sep 17 00:00:00 2001
From: McKinley Olsen <mck.olsen@gmail.com>
Date: Tue, 31 May 2016 14:28:44 -0600
Subject: [PATCH] gnu: Add vte-ng.
MIME-Version: 1.0
Content-Type: text/plain; charset=UTF-8
Content-Transfer-Encoding: 8bit

* gnu/packages/gnome.scm (vte-ng): New variable.

Signed-off-by: 宋文武 <iyzsong@gmail.com>
---
 gnu/packages/gnome.scm | 33 +++++++++++++++++++++++++++++++++
 1 file changed, 33 insertions(+)

diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 0d9c946fd54..8384c76d66e 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -1787,6 +1787,39 @@ (define-public vte
 editors, IDEs, etc.")
     (license license:lgpl2.1+)))
 
+(define-public vte-ng
+  (package
+    (inherit vte)
+    (name "vte-ng")
+    (version "0.44.1.b")
+    (native-inputs
+     `(("gtk-doc" ,gtk-doc)
+       ("gperf" ,gperf)
+       ("autoconf" ,autoconf)
+       ("automake" ,automake)
+       ("libtool" ,libtool)
+       ,@(package-native-inputs vte)))
+    (source (origin
+              (method url-fetch)
+              (uri (string-append "https://github.com/thestinger/"
+                                  name "/archive/" version ".tar.gz"))
+              (file-name (string-append name "-" version ".tar.gz"))
+              (sha256
+               (base32
+                "1mhz4i1qkdlrs49vgm7nsrb60lry9v6wsgwsmji7fln1nyrp1pag"))))
+    (arguments
+      `(#:configure-flags '("CXXFLAGS=-Wformat=0")
+        #:phases (modify-phases %standard-phases
+                  (add-after 'unpack 'bootstrap
+                    (lambda _
+                      (setenv "NOCONFIGURE" "true")
+                      (zero? (system* "sh" "autogen.sh")))))))
+  (synopsis "Enhanced VTE terminal widget")
+  (description
+   "VTE is a library (libvte) implementing a terminal emulator widget for
+GTK+, this fork provides additional functions exposed for keyboard text
+selection and URL hints.")))
+
 ;; provides vte 2.90, required for some terminal emulators
 ;; tilda bug: https://github.com/lanoxx/tilda/issues/94
 ;; pantheon-terminal bug: https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=788021
-- 
GitLab