diff --git a/gnu-system.am b/gnu-system.am
index 1e912db2309c51ca2c86fca5a4e246835f013882..9594e117f358a10650482bc57771d3d53c4de39a 100644
--- a/gnu-system.am
+++ b/gnu-system.am
@@ -310,6 +310,7 @@ dist_patch_DATA =						\
   gnu/packages/patches/guile-1.8-cpp-4.5.patch			\
   gnu/packages/patches/guile-default-utf8.patch			\
   gnu/packages/patches/guile-linux-syscalls.patch		\
+  gnu/packages/patches/guile-ncurses-tests.patch		\
   gnu/packages/patches/guile-relocatable.patch			\
   gnu/packages/patches/guix-test-networking.patch		\
   gnu/packages/patches/gtkglext-disable-disable-deprecated.patch \
diff --git a/gnu/packages/guile.scm b/gnu/packages/guile.scm
index 4c42d8234524fffa01f17d3ad47fa5487c245e3b..173365f6353f96143ea4506e3d421c5845923f3f 100644
--- a/gnu/packages/guile.scm
+++ b/gnu/packages/guile.scm
@@ -242,7 +242,8 @@ (define-public guile-ncurses
                                  version ".tar.gz"))
              (sha256
               (base32
-               "070wl664lsm14hb6y9ch97x9q6cns4k6nxgdzbdzi5byixn74899"))))
+               "070wl664lsm14hb6y9ch97x9q6cns4k6nxgdzbdzi5byixn74899"))
+             (patches (list (search-patch "guile-ncurses-tests.patch")))))
     (build-system gnu-build-system)
     (inputs `(("ncurses" ,ncurses)
               ("guile" ,guile-2.0)))
diff --git a/gnu/packages/patches/guile-ncurses-tests.patch b/gnu/packages/patches/guile-ncurses-tests.patch
new file mode 100644
index 0000000000000000000000000000000000000000..483b05a4ef00b628d3632d224320579343ea9c33
--- /dev/null
+++ b/gnu/packages/patches/guile-ncurses-tests.patch
@@ -0,0 +1,15 @@
+The wide test files are missing from the tarball, so ignore them.
+Reported at <https://lists.gnu.org/archive/html/bug-guile-ncurses/2014-06/msg00000.html>.
+
+--- guile-ncurses-1.4/test/Makefile.in	2013-04-27 17:55:19.000000000 +0200
++++ guile-ncurses-1.4/test/Makefile.in	2014-06-16 21:39:40.000000000 +0200
+@@ -258,8 +258,7 @@ m011_menu_options.test slk_001_init.test
+ slk_003_init.test slk_004_init.test slk_005_demo.test			\
+ slk_006_attributes.test
+ 
+-WIDETESTS = r037_border_set.test r038_get_wch.test r039_get_wstr.test	\
+-r040_term_attrs.test
++WIDETESTS =
+ 
+ TESTS = $(NOTERMTESTS) $(am__append_1) $(am__append_2)
+ EXTRA_DIST = $(TESTLIB) $(TESTS)