diff --git a/gnu/packages/admin.scm b/gnu/packages/admin.scm
index f28c768cebfecdc0acf93f607f3a61b7a5347565..bbf5e0b8048f603255ce946db67f19911f4efbf4 100644
--- a/gnu/packages/admin.scm
+++ b/gnu/packages/admin.scm
@@ -997,10 +997,10 @@ (define-public direvent
     (synopsis "Daemon to monitor directories for events such as file removal")
     (description
      "A daemon that monitors directories for events, such as creating,
-deleting or modifying files.  It can monitor different sets of directories for
+deleting or modifying files. It can monitor different sets of directories for
 different events.  When an event is detected, direvent calls a specified
 external program with information about the event, such as the location
-within the file system where it occurred.  Thus, \"direvent\" provides an easy
-way to react immediately if given files undergo changes, for example, to
+within the file system where it occurred.  Thus, \"direvent\" provides an
+easy way to react immediately if given files undergo changes, for example, to
 track changes in important system configuration files.")
     (license gpl3+)))
diff --git a/gnu/packages/base.scm b/gnu/packages/base.scm
index 49a2c83dd545a8fce2db12277fd3632c87514dd3..debfa9750974df82e247ee2d6498cc1405c99203 100644
--- a/gnu/packages/base.scm
+++ b/gnu/packages/base.scm
@@ -351,10 +351,11 @@ (define-public binutils
    (synopsis "Binary utilities: bfd gas gprof ld")
    (description
     "GNU Binutils is a collection of tools for working with binary files.
-Perhaps the most notable are \"ld\", a linker, and \"as\", an assembler. Other
-tools include programs to display binary profiling information, list the
-strings in a binary file, and utilities for working with archives.  The \"bfd\"
-library for working with executable and object formats is also included.")
+Perhaps the most notable are \"ld\", a linker, and \"as\", an assembler.
+Other tools include programs to display binary profiling information, list
+the strings in a binary file, and utilities for working with archives.  The
+\"bfd\" library for working with executable and object formats is also
+included.")
    (license gpl3+)
    (home-page "http://www.gnu.org/software/binutils/")))
 
diff --git a/gnu/packages/cpio.scm b/gnu/packages/cpio.scm
index 2c6e5efdba8b11d8f252cf2af5c4b3c1ffdc5c5b..eff146ded5ad7d09c8f3b9c2e5a3daf344e3df1b 100644
--- a/gnu/packages/cpio.scm
+++ b/gnu/packages/cpio.scm
@@ -39,9 +39,9 @@ (define-public cpio
     (home-page "https://www.gnu.org/software/cpio/")
     (synopsis "Manage cpio and tar file archives")
     (description
-     "GNU cpio copies files into or out of cpio or tar archives. Indeed,
+     "GNU cpio copies files into or out of cpio or tar archives.  Indeed,
 many formats are supported, including legacy formats.  The format is
-determined automatically by the program and is handled appropriately. 
+determined automatically by the program and is handled appropriately.
 Furthermore, the location of the archive is not important.  It can be another
 file on the drive, a tape, or data on a pipe.")
     (license gpl3+)))
diff --git a/gnu/packages/databases.scm b/gnu/packages/databases.scm
index 01d9cbdd62c8b6399706f1fac963cafc9ff9922e..d4fc000993e90bfc6676f60f018a2a72ef2b7141 100644
--- a/gnu/packages/databases.scm
+++ b/gnu/packages/databases.scm
@@ -204,8 +204,8 @@ (define-public recutils
      "GNU Recutils is a set of tools and libraries for creating and
 manipulating text-based, human-editable databases.  Despite being text-based,
 databases created with Recutils carry all of the expected features such as
-unique fields, primary keys, time stamps and more. Many different field types
-are supported, as is encryption.")
+unique fields, primary keys, time stamps and more.  Many different field
+types are supported, as is encryption.")
     (license gpl3+)
     (home-page "http://www.gnu.org/software/recutils/")))
 
diff --git a/gnu/packages/ed.scm b/gnu/packages/ed.scm
index dd0250647ae7ae552cf5e90c16601c27f58dd658..c2b19292f02719a9082b433bec0136f3c71dd91d 100644
--- a/gnu/packages/ed.scm
+++ b/gnu/packages/ed.scm
@@ -50,6 +50,6 @@ (define-public ed
      "Ed is a line-oriented text editor: rather than offering an overview of
 a document, ed performs editing one line at a time.  It can be executed both
 interactively and via shell scripts.  Its method of command input allows
-complex tasks to be performed in an automated way. GNU ed offers several
+complex tasks to be performed in an automated way.  GNU ed offers several
 extensions over the standard utility.")
     (license gpl3+)))
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index f3c88c92d486a5105c555f5aa8e0b6f1e2bf1ed2..1a911b76a9b4e3d4d8798e5e0a37429d3e28eace 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -100,7 +100,7 @@ (define-public gnubik
      "GNUbik is a puzzle game in which you must manipulate a cube to make
 each of its faces have a uniform color.  The game is customizable, allowing
 you to set the size of the cube (the default is 3x3) or to change the colors.
- You may even apply photos to the faces instead of colors.  The game is
+You may even apply photos to the faces instead of colors.  The game is
 scriptable with Guile.")
     (license gpl3+)))
 
diff --git a/gnu/packages/gawk.scm b/gnu/packages/gawk.scm
index 6185409fb7e44eb05561ad3634aa01f419b17758..0037419f65d6ae9306352f5b23e6f15dd513aeff 100644
--- a/gnu/packages/gawk.scm
+++ b/gnu/packages/gawk.scm
@@ -79,6 +79,6 @@ (define-public gawk
    (description
     "Gawk is the GNU implementation of Awk, a specialized programming
 language for the easy manipulation of formatted text, such as tables of data.
- Gawk features many extensions beyond the traditional implementation,
+Gawk features many extensions beyond the traditional implementation,
 including network access, sorting, and large libraries.")
    (license gpl3+)))
diff --git a/gnu/packages/gnuzilla.scm b/gnu/packages/gnuzilla.scm
index 14f75bff4559c9e7b95a08e82805dd5eb856d5eb..311ebbee8bb20e324ae0012b5e7651fe947dc45a 100644
--- a/gnu/packages/gnuzilla.scm
+++ b/gnu/packages/gnuzilla.scm
@@ -137,6 +137,6 @@ (define-public icecat
     (synopsis "Entirely free browser derived from Mozilla Firefox")
     (description
      "IceCat is the GNU version of the Firefox browser.  It is entirely free
-software, which does not recommend non-free plugins and addons. It also
+software, which does not recommend non-free plugins and addons.  It also
 features built-in privacy-protecting features.")
     (license license:mpl2.0))) ; and others, see toolkit/content/license.html
diff --git a/gnu/packages/gperf.scm b/gnu/packages/gperf.scm
index d9e80337d4f2851be150c8d78236a4d92f475274..9d9aaba3ce24c0ec799b8491c1ab3e77a832e8a5 100644
--- a/gnu/packages/gperf.scm
+++ b/gnu/packages/gperf.scm
@@ -39,8 +39,8 @@ (define-public gperf
     (home-page "http://www.gnu.org/software/gperf/")
     (synopsis "Perfect hash function generator")
     (description
-     "gperf is a perfect hash function generator.  For a given list of strings,
-it produces a hash function and hash table in C or C++ code. That the hash
-function is perfect means that no collisions can exist and that look-ups can be
-made by single string comparisons.")
+     "gperf is a perfect hash function generator.  For a given list of
+strings, it produces a hash function and hash table in C or C++ code.  That
+the hash function is perfect means that no collisions can exist and that
+look-ups can be made by single string comparisons.")
     (license gpl3+)))
diff --git a/gnu/packages/grub.scm b/gnu/packages/grub.scm
index fabbbc439dda03ce186a69560fd3356e80de2c28..398a6d4e49083a95586085524ef16b874814271c 100644
--- a/gnu/packages/grub.scm
+++ b/gnu/packages/grub.scm
@@ -101,7 +101,7 @@ (define-public grub
     (description
      "GRUB is a multiboot bootloader.  It is used for initially loading the
 kernel of an operating system and then transferring control to it. The kernel
-then goes on to load the rest of the operating system. As a multiboot
+then goes on to load the rest of the operating system.  As a multiboot
 bootloader, GRUB handles the presence of multiple operating systems installed
 on the same computer; upon booting the computer, the user is presented with a
 menu to select one of the installed operating systems.")
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index 774686310f36ee0067c0e7e5df2dc4e687ea3184..bd279099e2e91309d484d6078496878f755c466c 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -179,11 +179,11 @@ (define-public pspp
     (synopsis "Statistical analysis")
     (description
      "GNU PSPP is a statistical analysis program.  It can perform
-descriptive statistics, T-tests, linear regression and non-parametric tests. 
-It features both a graphical interface as well as command-line input. PSPP is
-designed to interoperate with Gnumeric, LibreOffice and OpenOffice.  Data can
-be imported from spreadsheets, text files and database sources and it can be
-output in text, PostScript, PDF or HTML.")
+descriptive statistics, T-tests, linear regression and non-parametric tests.
+It features both a graphical interface as well as command-line input.  PSPP
+is designed to interoperate with Gnumeric, LibreOffice and OpenOffice.  Data
+can be imported from spreadsheets, text files and database sources and it can
+be output in text, PostScript, PDF or HTML.")
     (license license:gpl3+)))
 
 (define-public lapack
diff --git a/gnu/packages/package-management.scm b/gnu/packages/package-management.scm
index 9f35de18194f8f7ae8f2cb4e3f90565fe4854654..b789b333b8b7d30b5a4c695f6a0c3cec587d5cf3 100644
--- a/gnu/packages/package-management.scm
+++ b/gnu/packages/package-management.scm
@@ -103,10 +103,10 @@ (define (copy arch)
     (synopsis "Functional package manager for installed software packages and versions")
     (description
      "GNU Guix is a functional package manager for the GNU system, and is
-also a distribution thereof.  It includes a virtual machine image. Besides
+also a distribution thereof.  It includes a virtual machine image.  Besides
 the usual package management features, it also supports transactional
-upgrades and roll-backs, per-user profiles, and much more. It is based on the
-Nix package manager.")
+upgrades and roll-backs, per-user profiles, and much more.  It is based on
+the Nix package manager.")
     (license gpl3+)))
 
 (define-public guix guix-0.7)
diff --git a/gnu/packages/pth.scm b/gnu/packages/pth.scm
index fd4aba142cc3d8f38019e76724a8f271fb4f1b18..ba5fb8216d0b1dde6b03ca31173c204212c391fb 100644
--- a/gnu/packages/pth.scm
+++ b/gnu/packages/pth.scm
@@ -48,7 +48,7 @@ (define-public pth
     (description
      "GNU Pth is a portable library providing non-preemptive, priority-based
 scheduling for multiple execution threads.  Each thread has its own
-program-counter, run-time stack, signal mask and errno variable. Threads are
+program-counter, run-time stack, signal mask and errno variable.  Threads are
 scheduled in a cooperative way, rather than in the standard preemptive way,
 such that they are managed according to priority and events.  However, Pth
 also features emulation of POSIX.1c threads (\"pthreads\") for backwards
diff --git a/gnu/packages/rush.scm b/gnu/packages/rush.scm
index c0450834f66c098b138974040cf83aa28cb4d7bc..0a65599e24f3210a8ec5f69f7ef8446dbb5d85f0 100644
--- a/gnu/packages/rush.scm
+++ b/gnu/packages/rush.scm
@@ -42,7 +42,7 @@ (define-public rush
     (synopsis "Restricted user (login) shell")
     (description
      "GNU Rush is a restricted user shell, for systems on which users are to
-be provided with only limited functionality or resources. Administrators set
+be provided with only limited functionality or resources.  Administrators set
 user rights via a configuration file which can be used to limit, for example,
 the commands that can be executed, CPU time, or virtual memory usage.")
     (license gpl3+)))