From c5a6e33b5659925f8c56d93ee97e846ef2c42d4b Mon Sep 17 00:00:00 2001
From: Efraim Flashner <efraim@flashner.co.il>
Date: Tue, 16 Feb 2016 12:13:01 +0200
Subject: [PATCH] gnu: gpsbabel: Use 'modify-phases'.

* gnu/packages/gps.scm (gpsbabel)[arguments]: Use 'modify-phases'.
---
 gnu/packages/gps.scm | 12 ++++++------
 1 file changed, 6 insertions(+), 6 deletions(-)

diff --git a/gnu/packages/gps.scm b/gnu/packages/gps.scm
index 1e8f3afbca8..fd045b1f1a3 100644
--- a/gnu/packages/gps.scm
+++ b/gnu/packages/gps.scm
@@ -49,12 +49,12 @@ (define-public gpsbabel
     (build-system gnu-build-system)
     (arguments
      `(#:configure-flags '("--with-zlib=system")
-       #:phases (alist-cons-before
-                 'configure 'pre-configure
-                 (lambda _
-                   (chdir "gpsbabel"))
-                 ;; TODO: "make doc" requires Docbook & co.
-                 %standard-phases)
+       #:phases
+       (modify-phases %standard-phases
+        (add-before 'configure 'pre-configure
+                    (lambda _
+                      (chdir "gpsbabel"))))
+                    ;; TODO: "make doc" requires Docbook & co.
 
        ;; On i686, 'raymarine.test' fails because of a rounding error:
        ;; <http://hydra.gnu.org/build/133040>.  As a workaround, disable tests
-- 
GitLab