diff --git a/gnu/packages/enchant.scm b/gnu/packages/enchant.scm
index 64f8a34778dabaf4f6565feeb13cad01650a766d..75b330f83b485b4d11973535ec4aae89cb5e937f 100644
--- a/gnu/packages/enchant.scm
+++ b/gnu/packages/enchant.scm
@@ -94,8 +94,9 @@ (define-public enchant
                            ;; Tests require a relocatable build.
                            "--enable-relocatable")))
     (inputs
-     `(("aspell" ,aspell)))   ;; Currently, the only supported backend in Guix
-    (propagated-inputs        ;; is aspell. (This information might be old)
+     `(("aspell" ,aspell)
+       ("hunspell" ,hunspell)))
+    (propagated-inputs
      ;; Required by enchant.pc.
      `(("glib" ,glib)))
     (native-inputs