From c661f25a944133dbdadcd185fd7cd4762419d254 Mon Sep 17 00:00:00 2001
From: Efraim Flashner <efraim@flashner.co.il>
Date: Sun, 2 Dec 2018 13:04:37 +0200
Subject: [PATCH] gnu: ocaml@4.01: Enable building on aarch64-linux.

This reverts 454e7132d6fffb5c9a5ce086ffd1b687416feb83.

* gnu/packages/ocaml.scm (ocaml@4.01)[supported-systems]: Remove field.
[arguments]: When building on aarch64-linux, replace the custom
'configure script.
---
 gnu/packages/ocaml.scm | 14 ++++++++++++--
 1 file changed, 12 insertions(+), 2 deletions(-)

diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index c25f7c0858f..11389440dcb 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -249,6 +249,17 @@ (define-public ocaml-4.01
              (lambda _
                ;; Specifying '-j' at all causes the build to fail.
                (zero? (system* "make" "world.opt"))))
+           ,@(if (string=? "aarch64-linux" (%current-system))
+               ;; Custom configure script doesn't recongnize aarch64.
+               '((replace 'configure
+                  (lambda* (#:key outputs #:allow-other-keys)
+                    (let* ((out (assoc-ref outputs "out"))
+                           (mandir (string-append out "/share/man")))
+                      (invoke "./configure"
+                              "--prefix" out
+                              "--mandir" mandir
+                              "-host" "armv8l-unknown-linux-gnu")))))
+               '())
            (replace 'check
              (lambda _
                (with-directory-excursion "testsuite"
@@ -256,8 +267,7 @@ (define-public ocaml-4.01
                          "make"
                          "all"
                          (string-append
-                          "TOPDIR=" (getcwd) "/.."))))))))))
-    (supported-systems (delete "aarch64-linux" %supported-systems))))
+                          "TOPDIR=" (getcwd) "/.."))))))))))))
 
 (define-public ocaml-4.07
   (package
-- 
GitLab