From c8d68ff9c3763abd24473dd2d414e581ef5ca059 Mon Sep 17 00:00:00 2001
From: Eric Bavier <bavier@member.fsf.org>
Date: Thu, 5 Mar 2015 17:01:58 -0600
Subject: [PATCH] gnu: Add Scalar-List-Utils.

* gnu/packages/perl.scm (perl-scalar-list-utils): New variable.
---
 gnu/packages/perl.scm | 21 +++++++++++++++++++++
 1 file changed, 21 insertions(+)

diff --git a/gnu/packages/perl.scm b/gnu/packages/perl.scm
index 49fbe5c303d..8a99ab77136 100644
--- a/gnu/packages/perl.scm
+++ b/gnu/packages/perl.scm
@@ -2104,4 +2104,25 @@ (define-public perl-parse-cpan-meta
 files, using JSON::PP and/or CPAN::Meta::YAML.")
     (license (package-license perl))))
 
+(define-public perl-scalar-list-utils
+  (package
+    (name "perl-scalar-list-utils")
+    (version "1.41")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append "mirror://cpan/authors/id/P/PE/PEVANS/"
+                           "Scalar-List-Utils-" version ".tar.gz"))
+       (sha256
+        (base32
+         "04l1q4hps9n8b1hk9kpgpc1cryim7pl9sfdyb7fz5nq4gmz307j7"))))
+    (build-system perl-build-system)
+    (home-page "http://search.cpan.org/dist/Scalar-List-Utils")
+    (synopsis "Common Scalar and List utility subroutines")
+    (description "This package contains a selection of subroutines that people
+have expressed would be nice to have in the perl core, but the usage would not
+really be high enough to warrant the use of a keyword, and the size so small
+such that being individual extensions would be wasteful.")
+    (license (package-license perl))))
+
 ;;; END: Core module overrides
-- 
GitLab