diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index e30166c133cdb9da8fa4813076a57c41ad4b79bc..9558dcc9f4acb403aa15a8de9150cc4f01e9a380 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -9221,9 +9221,10 @@ (define-public python-pykafka
     (build-system python-build-system)
     (arguments '(#:tests? #f)) ; XXX: needs zookeeper, kafka, etc.
     (native-inputs
+     `(("python-setuptools" ,python-setuptools)))
+    (propagated-inputs
      `(("python-gevent" ,python-gevent)
        ("python-kazoo" ,python-kazoo)
-       ("python-setuptools" ,python-setuptools)
        ("python-tabulate" ,python-tabulate)))
     (inputs
      `(("librdkafka" ,librdkafka)))