From c94d01bab2714b963048e965955652d0f91ebd56 Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Ludovic=20Court=C3=A8s?= <ludo@gnu.org>
Date: Sat, 14 Dec 2013 19:23:29 +0100
Subject: [PATCH] gnu: tzdata: Fix cross-compilation.

Reported by John Darrington <john@darrington.wattle.id.au>.

* gnu/packages/base.scm (tzdata): Use the 'source' keyword argument in
  phases rather than the "source" input.  This fixes cross-compilation.
---
 gnu/packages/base.scm | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/gnu/packages/base.scm b/gnu/packages/base.scm
index 02f1b91392e..e17933b36fb 100644
--- a/gnu/packages/base.scm
+++ b/gnu/packages/base.scm
@@ -520,8 +520,8 @@ (define-public tzdata
        #:phases
        (alist-replace
         'unpack
-        (lambda* (#:key inputs #:allow-other-keys)
-          (and (zero? (system* "tar" "xvf" (assoc-ref inputs "source")))
+        (lambda* (#:key source inputs #:allow-other-keys)
+          (and (zero? (system* "tar" "xvf" source))
                (zero? (system* "tar" "xvf" (assoc-ref inputs "tzcode")))))
         (alist-cons-after
          'install 'post-install
-- 
GitLab