From c971d9ef29a22f99565a92e55cacf1b06c8d1011 Mon Sep 17 00:00:00 2001
From: Dave Love <fx@gnu.org>
Date: Mon, 2 Oct 2017 21:54:43 +0100
Subject: [PATCH] gnu: openmpi: Add "debug" output.
MIME-Version: 1.0
Content-Type: text/plain; charset=UTF-8
Content-Transfer-Encoding: 8bit

This is necessary for one mechanism for attaching parallel debuggers
and is also relevant for the runtime backtrace facility.

* gnu/packages/mpi.scm (openmpi)[outputs]: New field.

Signed-off-by: Ludovic Courtès <ludo@gnu.org>
---
 gnu/packages/mpi.scm | 1 +
 1 file changed, 1 insertion(+)

diff --git a/gnu/packages/mpi.scm b/gnu/packages/mpi.scm
index 517f9124177..98b21219f5d 100644
--- a/gnu/packages/mpi.scm
+++ b/gnu/packages/mpi.scm
@@ -131,6 +131,7 @@ (define-public openmpi
     (native-inputs
      `(("pkg-config" ,pkg-config)
        ("perl" ,perl)))
+    (outputs '("out" "debug"))
     (arguments
      `(#:configure-flags `("--enable-mpi-ext=affinity" ;cr doesn't work
                            "--enable-memchecker"
-- 
GitLab