diff --git a/gnu/packages/openstack.scm b/gnu/packages/openstack.scm
index fa99ffb2b03d1a905bd9e30d58d92e1b38303179..2906a574cffe0b6a11abc38b49a3b77a9e292dd4 100644
--- a/gnu/packages/openstack.scm
+++ b/gnu/packages/openstack.scm
@@ -626,7 +626,7 @@ (define-public python-oslosphinx
              ;; Note: Upstream tests would have also built the release notes.
              ;; That only would work if we were in a git checkout.
              ;; Therefore, we don't do it here.
-             (zero? (system* "python" "setup.py" "build_sphinx")))))))
+             (invoke "python" "setup.py" "build_sphinx"))))))
     (propagated-inputs
       `(("python-requests" ,python-requests)))
     (native-inputs