diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 387087e544b11701069d2f1b7bbac1711967c897..6a88f6805e3eef0e5973ee7f3dd99acf26f63229 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -448,8 +448,8 @@ (define-public linux-libre-headers-5.1
   (make-linux-libre-headers %linux-libre-version
                             %linux-libre-hash))
 
-(define %linux-libre-4.19-version "4.19.57")
-(define %linux-libre-4.19-hash "0p9b27hfbzppxgad9q2g7nvfzv0phzdsk16sqy87q3dglc8wqrqq")
+(define %linux-libre-4.19-version "4.19.58")
+(define %linux-libre-4.19-hash "0i2mh0zk1h1niba1bpd49bn938sdn3qrwzkqpqzimxnj31xcjhyz")
 
 (define %linux-libre-4.19-patches
   (list %boot-logo-patch