From cca5720f410ce01e2b3ed7e4fde593e118f08f07 Mon Sep 17 00:00:00 2001
From: Leo Famulari <leo@famulari.name>
Date: Tue, 15 Sep 2020 19:57:48 -0400
Subject: [PATCH] gnu: Fix fetching the linux-libre deblobbing script.

This is a followup to commit 105a037090d9a970a2c2336341d6673eff29e4cf.

* gnu/packages/linux.scm (linux-libre-deblob-scripts): Truncate the version in
the file-name, not the source URI.
---
 gnu/packages/linux.scm | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 59ffb334e00..2e47b81cf6b 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -195,9 +195,9 @@ (define (linux-libre-deblob-scripts version
           (method url-fetch)
           (uri (string-append "https://linux-libre.fsfla.org"
                               "/pub/linux-libre/releases/" version "-gnu/"
-                              "deblob-" version))
+                              "deblob-" (version-major+minor version)))
           (file-name (string-append "linux-libre-deblob-"
-                                    (version-major+minor version)))
+                                    version))
           (sha256 deblob-hash))
         (origin
           (method url-fetch)
-- 
GitLab