diff --git a/gnu/packages/upnp.scm b/gnu/packages/upnp.scm
index 67c479a39b954df465f4304ad04b0b3f633fe1c2..35bacc75f661b64d87137e687e51089b56cd6629 100644
--- a/gnu/packages/upnp.scm
+++ b/gnu/packages/upnp.scm
@@ -54,7 +54,8 @@ (define-public miniupnpc
         (string-append "LDFLAGS=-Wl,-rpath="
                        (assoc-ref %outputs "out") "/lib"))
        #:phases
-       (alist-delete 'configure %standard-phases)))
+       (modify-phases %standard-phases
+         (delete 'configure))))
     (home-page "http://miniupnp.free.fr/")
     (synopsis "Library implementing the client side UPnP protocol")
     (description