diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index 702704ed468ed3e50ee416657e8afa8d4de967c6..1dcb0aa8e17b897bdf8e292248fcf41cb502036b 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -1001,7 +1001,7 @@ (define-public libvpx
 (define-public youtube-dl
   (package
     (name "youtube-dl")
-    (version "2017.06.05")
+    (version "2017.06.12")
     (source (origin
               (method url-fetch)
               (uri (string-append "https://yt-dl.org/downloads/"
@@ -1009,7 +1009,7 @@ (define-public youtube-dl
                                   version ".tar.gz"))
               (sha256
                (base32
-                "132f4csbl4bv71b01pnqfkd7hbbc6wclrh1h12fr1182954ahk5m"))))
+                "1p4d8g44v8vgr4xwvmbvzkjz6zakl2r89spaak6yw1zxmymd9b1w"))))
     (build-system python-build-system)
     (arguments
      ;; The problem here is that the directory for the man page and completion