diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 2a83da6e9dc8689788deb39bc2c5274247fcdec9..755fd59294a06e7f0f8fb69f9841f8debaacea64 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -9839,10 +9839,11 @@ (define-public python-urllib3
        ("python-mock" ,python-mock)
        ("python-tornado" ,python-tornado)))
     (propagated-inputs
-     `(;; extra packages for https security
+     `(;; These 5 inputs are used to build urrlib3[secure]
        ("python-certifi" ,python-certifi)
-       ("python-ndg-httpsclient" ,python-ndg-httpsclient)
-       ("python-pyasn1" ,python-pyasn1)
+       ("python-cryptography" ,python-cryptography) ;
+       ("python-idna" ,python-idna)
+       ("python-ipaddress" ,python-ipaddress)
        ("python-pyopenssl" ,python-pyopenssl)))
     (home-page "https://urllib3.readthedocs.org/")
     (synopsis "HTTP library with thread-safe connection pooling")