diff --git a/gnu/packages/base.scm b/gnu/packages/base.scm
index 4452108abf30d36280b3815ab7fc071c2f295a0c..85380549ff85022bbe1fe2f2833a51250096da0f 100644
--- a/gnu/packages/base.scm
+++ b/gnu/packages/base.scm
@@ -236,13 +236,13 @@ (define-public findutils
     `(("patch/absolute-paths"
        ,(search-patch "findutils-absolute-paths.patch"))))
    (arguments
-    `(#:patches (list (assoc-ref %build-inputs "patch/absolute-paths")))
+    `(#:patches (list (assoc-ref %build-inputs "patch/absolute-paths"))
 
-    ;; TODO: Work around cross-compilation failure.
-    ;; See <http://savannah.gnu.org/bugs/?27299#comment1>.
-    ;; `(#:configure-flags '("gl_cv_func_wcwidth_works=yes")
-    ;;   ,@(arguments cross-system))
-    )
+      ;; Work around cross-compilation failure.
+      ;; See <http://savannah.gnu.org/bugs/?27299#comment1>.
+      ,@(if (%current-target-system)
+            '(#:configure-flags '("gl_cv_func_wcwidth_works=yes"))
+            '())))
    (synopsis "Operating on files matching given criteria")
    (description
     "The GNU Find Utilities are the basic directory searching utilities of