diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 0f9241edfc7facaf0f9d5290ab7b029bca7d92bb..8e77b5f76e71df5bca424aa3faa58b7cca463176 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -8946,7 +8946,8 @@ (define-public gspell
               (patches (search-patches "gspell-dash-test.patch"))))
     (build-system glib-or-gtk-build-system)
     (arguments
-     '(#:phases
+     '(#:configure-flags (list "--enable-vala")
+       #:phases
        (modify-phases %standard-phases
          (add-before 'check 'pre-check
            (lambda* (#:key inputs #:allow-other-keys)
@@ -8971,6 +8972,7 @@ (define-public gspell
      `(("glib" ,glib "bin")
        ("gobject-introspection" ,gobject-introspection)
        ("pkg-config" ,pkg-config)
+       ("vala" ,vala)                             ;for VAPI, needed by Geary
        ("xmllint" ,libxml2)
 
        ;; For tests.