diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index c0ed19e16cbfc95516ac4903ab3346613279b6fe..d13d7dbd8d934c756a21d4700a81950d0801240c 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -271,12 +271,9 @@ (define-public python-2.7
                                  (scandir testdir
                                           (match-lambda
                                             ((or "." "..") #f)
+                                            ("support" #f)
                                             (file
                                              (not
-                                              ;; FIXME: Add the 'support' directory
-                                              ;; in the next rebuild cycle, since it
-                                              ;; moved in 2.7.14.  See also
-                                              ;; python2-futures below.
                                               (string-prefix? "test_support."
                                                               file))))))
                        (call-with-output-file "__init__.py" (const #t))