From d453b0e11d3f001a8160a7d126fdbf40e45d5042 Mon Sep 17 00:00:00 2001
From: Christopher Baines <mail@cbaines.net>
Date: Thu, 3 Jan 2019 20:47:39 +0000
Subject: [PATCH] gnu: python-2.7: Include /lib/python.../test/support.

Don't remove the support directory from the /lib/python.../test/ directory, as
this is used from the test_support module.

  /gnu/store/...-python2-2.7.15/lib/python2.7/test/test_support.py:2: in <module>
      import test.support
  E   ImportError: No module named support

* gnu/packages/python.scm (python-2.7)[arguments]: Change the 'remove-tests
phase to not remove the support directory.
---
 gnu/packages/python.scm | 5 +----
 1 file changed, 1 insertion(+), 4 deletions(-)

diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index c0ed19e16cb..d13d7dbd8d9 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -271,12 +271,9 @@ (define-public python-2.7
                                  (scandir testdir
                                           (match-lambda
                                             ((or "." "..") #f)
+                                            ("support" #f)
                                             (file
                                              (not
-                                              ;; FIXME: Add the 'support' directory
-                                              ;; in the next rebuild cycle, since it
-                                              ;; moved in 2.7.14.  See also
-                                              ;; python2-futures below.
                                               (string-prefix? "test_support."
                                                               file))))))
                        (call-with-output-file "__init__.py" (const #t))
-- 
GitLab