From d56af1ff62a3759c323fec8760abf2a3e13c7dad Mon Sep 17 00:00:00 2001
From: Tobias Geerinckx-Rice <me@tobias.gr>
Date: Mon, 18 Feb 2019 23:32:54 +0100
Subject: [PATCH] gnu: protozero: Don't use unstable tarball.

* gnu/packages/geo.scm (protozero)[source]: Use GIT-FETCH and
GIT-FILE-NAME.
---
 gnu/packages/geo.scm | 12 +++++++-----
 1 file changed, 7 insertions(+), 5 deletions(-)

diff --git a/gnu/packages/geo.scm b/gnu/packages/geo.scm
index 8a8d220779d..d95547763ec 100644
--- a/gnu/packages/geo.scm
+++ b/gnu/packages/geo.scm
@@ -32,6 +32,7 @@ (define-module (gnu packages geo)
   #:use-module (guix build-system scons)
   #:use-module (guix build-system r)
   #:use-module (guix download)
+  #:use-module (guix git-download)
   #:use-module ((guix licenses) #:prefix license:)
   #:use-module (guix packages)
   #:use-module (guix utils)
@@ -746,12 +747,13 @@ (define-public protozero
     (version "1.6.5")
     (source
      (origin
-       (method url-fetch)
-       (uri (string-append "https://github.com/mapbox/protozero/archive/v"
-                           version ".tar.gz"))
-       (file-name (string-append name "-" version ".tar.gz"))
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/mapbox/protozero.git")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
        (sha256
-        (base32 "0y12wz9v5w2gjfipyrw7v1gchnhivzlkkfax37i69l3yp9npimly"))))
+        (base32 "10ldzni46cplmkgx1f73yn95qcb71xh9nxpcfdmi107y3kvicv3c"))))
     (build-system cmake-build-system)
     (home-page "https://github.com/mapbox/protozero")
     (synopsis "Minimalistic protocol buffer decoder and encoder in C++")
-- 
GitLab