diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 17147b96bcf4b9bd20b426ef693567dc21eeb42a..ad5def2a8cd66cd75efa3884f46ebcc4ab51c82f 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -995,3 +995,29 @@ (define-public python-exif-read
 
 (define-public python2-exif-read
   (package-with-python2 python-exif-read))
+
+(define-public python-pyld
+  (package
+    (name "python-pyld")
+    (version "0.6.0")
+    (source (origin
+              (method url-fetch)
+              (uri
+               (string-append
+                "https://pypi.python.org/packages/source/P/PyLD/PyLD-"
+                version ".tar.gz"))
+              (sha256
+               (base32
+                "1l9ymj85fsvayqplinzpk0kyiq6m74ps9xd3a9fhlxfn1rldf8x8"))))
+    (build-system python-build-system)
+    (inputs
+     `(("python-setuptools" ,python-setuptools)))
+    (arguments `(#:tests? #f)) ; no tests
+    (home-page "http://github.com/digitalbazaar/pyld")
+    (synopsis "Python implementation of the JSON-LD specification")
+    (description
+     "PyLD is an implementation of the JSON-LD specification.")
+    (license bsd-3)))
+
+(define-public python2-pyld
+  (package-with-python2 python-pyld))