From d7b83e2f8d8afebfb301db2e40b2f56e382d0510 Mon Sep 17 00:00:00 2001
From: Tobias Geerinckx-Rice <me@tobias.gr>
Date: Fri, 16 Oct 2020 16:47:41 +0200
Subject: [PATCH] gnu: filters: Replace git commit with equivalent tag.

* gnu/packages/toys.scm (filters)[source]: Use tag.
---
 gnu/packages/toys.scm | 106 +++++++++++++++++++++---------------------
 1 file changed, 52 insertions(+), 54 deletions(-)

diff --git a/gnu/packages/toys.scm b/gnu/packages/toys.scm
index eb727a4192d..0d0035a86ec 100644
--- a/gnu/packages/toys.scm
+++ b/gnu/packages/toys.scm
@@ -78,53 +78,51 @@ (define-public sl
                                    "See LICENSE in the distribution."))))
 
 (define-public filters
-  (let ((version "2.55")
-        (commit "c5c291916b52ed9e6418448a8eee30475fb9adcf"))
-    (package
-      (name "filters")
-      (version "2.55")
-      (source
-       (origin
-         (method git-fetch)
-         (uri (git-reference
-               (url "https://git.joeyh.name/filters")
-               (commit commit)))
-         (file-name (git-file-name name version))
-         (sha256
-          (base32 "1gaigpda1w9wxfh8an3sam1hpacc1bhxl696w4yj0vzhc6izqvxs"))
-         (modules '((guix build utils)))
-         (snippet '(begin
-                     ;; kenny is under nonfree Artistic License (Perl) 1.0.
-                     (delete-file "kenny")
-                     (substitute* "Makefile"
-                       (("kenny")
-                        ""))))))
-      (build-system gnu-build-system)
-      (arguments
-       `(#:make-flags
-         (list (string-append "CC=" ,(cc-for-target))
-               (string-append "DESTDIR=" %output))
-         #:phases
-         (modify-phases %standard-phases
-           (delete 'configure)
-           (add-after 'unpack 'fix-install-directories
-             (lambda _
-               (substitute* "Makefile"
-                 (("/usr/games")
-                  "/bin/")
-                 (("/usr/share/")
-                  "/share/"))
-               #t)))
-         #:tests? #f))                  ; no test suite
-      (native-inputs
-       `(("bison" ,bison)
-         ("flex" ,flex)))
-      (inputs
-       `(("perl" ,perl)))
-      (home-page "https://joeyh.name/code/filters/")
-      (synopsis "Various amusing text filters")
-      (description
-       "The filters collection harks back to the late 1980s, when various text
+  (package
+    (name "filters")
+    (version "2.55")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://git.joeyh.name/filters")
+             (commit version)))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "1gaigpda1w9wxfh8an3sam1hpacc1bhxl696w4yj0vzhc6izqvxs"))
+       (modules '((guix build utils)))
+       (snippet '(begin
+                   ;; kenny is under nonfree Artistic License (Perl) 1.0.
+                   (delete-file "kenny")
+                   (substitute* "Makefile"
+                     (("kenny")
+                      ""))))))
+    (build-system gnu-build-system)
+    (arguments
+     `(#:make-flags
+       (list (string-append "CC=" ,(cc-for-target))
+             (string-append "DESTDIR=" %output))
+       #:phases
+       (modify-phases %standard-phases
+         (delete 'configure)
+         (add-after 'unpack 'fix-install-directories
+           (lambda _
+             (substitute* "Makefile"
+               (("/usr/games")
+                "/bin/")
+               (("/usr/share/")
+                "/share/"))
+             #t)))
+       #:tests? #f))                    ; no test suite
+    (native-inputs
+     `(("bison" ,bison)
+       ("flex" ,flex)))
+    (inputs
+     `(("perl" ,perl)))
+    (home-page "https://joeyh.name/code/filters/")
+    (synopsis "Various amusing text filters")
+    (description
+     "The filters collection harks back to the late 1980s, when various text
 filters were written to munge written language in amusing ways.  The earliest
 and best known were legends such as the Swedish Chef filter and B1FF.
 
@@ -158,13 +156,13 @@ (define-public filters
 @end enumerate
 
 The GNU project hosts a similar collection of filters, the GNU talkfilters.")
-      (license                    ; see debian/copyright
-       (list license:gpl2+        ; most of the filters
-             license:gpl2         ; rasterman, ky00te.dir/* nethackify, pirate
-             license:gpl3+        ; scramble, scottish
-             license:public-domain      ; jethro, kraut, ken, studly
-             license:gpl1+         ; cockney, jive, nyc only say "gpl"
-             license:expat)))))    ; newspeak
+    (license                      ; see debian/copyright
+     (list license:gpl2+          ; most of the filters
+           license:gpl2           ; rasterman, ky00te.dir/* nethackify, pirate
+           license:gpl3+          ; scramble, scottish
+           license:public-domain  ; jethro, kraut, ken, studly
+           license:gpl1+          ; cockney, jive, nyc only say "gpl"
+           license:expat))))     ; newspeak
 
 (define-public xsnow
   (package
-- 
GitLab