diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index a66bdae150cb729eb621e7b6c2906abbddc0ccd8..734997ae57efe49ad7ff1abd874ea600bb0189f5 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -409,3 +409,23 @@ (define-public e2fsprogs
     (license (list gpl2                           ; programs
                    lgpl2.0                        ; libext2fs
                    x11))))                        ; libuuid
+
+(define-public strace
+  (package
+    (name "strace")
+    (version "4.7")
+    (source (origin
+             (method url-fetch)
+             (uri (string-append "mirror://sourceforge/strace/strace-"
+                                 version ".tar.xz"))
+             (sha256
+              (base32
+               "158iwk0pl2mfw93m1843xb7a2zb8p6lh0qim07rca6f1ff4dk764"))))
+    (build-system gnu-build-system)
+    (inputs `(("perl" ,perl)))
+    (home-page "http://strace.sourceforge.net/")
+    (synopsis "System call tracer for Linux")
+    (description
+     "strace is a system call tracer, i.e. a debugging tool which prints out a
+trace of all the system calls made by a another process/program.")
+    (license bsd-3)))