From d889e6c4d9af68701be3e8a12bc377369d1c8625 Mon Sep 17 00:00:00 2001
From: Cyril Roelandt <tipecaml@gmail.com>
Date: Fri, 26 Jun 2015 22:31:41 +0200
Subject: [PATCH] gnu: Add python-pep8.

* gnu/packages/python.scm (python-pep8, python2-pep8): New variables.
---
 gnu/packages/python.scm | 27 +++++++++++++++++++++++++++
 1 file changed, 27 insertions(+)

diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 1b3934b351a..0bcaf5df8e8 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -3902,3 +3902,30 @@ (define-public python-pyzmq
 
 (define-public python2-pyzmq
   (package-with-python2 python-pyzmq))
+
+(define-public python-pep8
+  (package
+    (name "python-pep8")
+    (version "1.6.2")
+    (source
+      (origin
+        (method url-fetch)
+        (uri (string-append
+               "https://pypi.python.org/packages/source/p/pep8/pep8-"
+               version
+               ".tar.gz"))
+        (sha256
+          (base32
+            "1zybkcdw1sx84dvkfss96nhykqg9bc0cdpwpl4k9wlxm61bf7dxq"))))
+    (build-system python-build-system)
+    (inputs
+      `(("python-setuptools" ,python-setuptools)))
+    (home-page "http://pep8.readthedocs.org/")
+    (synopsis "Python style guide checker")
+    (description
+     "This tools checks Python code against some of the style conventions in
+PEP 8.")
+    (license license:expat)))
+
+(define-public python2-pep8
+  (package-with-python2 python-pep8))
-- 
GitLab